M2 has arrived

My M2 has arrived just in time for a trip to Florida!!! I see they are shipping with 2.23.0 DEV firmware. It failed to check for updates when first setting it up so just ignore that unless some were shipped with a different firmware version? I am also unable to get the NTRIP caster correction input to work using the same web address as I do on my reach OG and M+. Will get a full system report.


Here is a full system report. I tried multiple ways to get my ntrip addresses (https://,wwww,http://, ect…) to work but none of them would connect. I also confirmed I was using the correct port and that they were operational within UNAVCO/RTK2go network which they were. I never got them to connect. As I was just messing around with settings the unit and antenna were not setup correctly as you can see from the photos. didn’t really care about obtaining a fix just getting things setup. When using an android device where do the system reports save to when downloading, I could not find them anywhere on my phone. Also seems there is an error when downloading via a android device as reachview will show download complete then immediately kick you out of the app.
SystemReport.zip (227.9 KB)

Hi Matthew,

Thanks for the report!

It seems like your unit is on v2.22.0 firmware version which is the current stable release.

I can see from your report that the mount point field for your NTRIP caster is empty. May I ask you to fill it and try connecting once again?

On Android it’s more likely you will find this file in My Files/Downloads or in My Files/Internal Storage/Download folders.

Unfortunately, this might occasionally happen on certain Android versions. We’re planning to fix this in the future versions of the App.

1 Like

thats odd, it said on the reachview app 2.23 dev, odd thing was I was connecting to reachview through my internet at the office but it would not ever find an update nor take or connect to the NTRIP caster address, but I was logging in using the ip found using the FING app so it was connected to my internet and I was able to browse the web with said internet connection. I took the device home and connected to my home network and was able to find an update to the newest reachview and was also able to connect to the caster so no issues there. It did clearly say 2.23 dev when I first started the reachview app when it never found an update in the beginning.

Not occasionally, every time I download logs with my note8 running the latest version of android it error’s out and you have to reconnect, never happens when using the browser.

Thats odd I entered it about 12 times so clearly something is not logging correctly in the system report when it doesn’t think its connected to the internet or possibly a firewall setting with the university internet.

Hi Matthew,

Do I understand correctly that you managed to configure correction input from via NTRIP?

Yes, i believe it was an error on the university network.

Hi Matthew,

Great to know everything works now!

It seems that the university network’s firewall was preventing Reach from connecting to the Internet.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.