M2 doesn't always turn on

I have two Reach M2’s on UAV, both powered by an adjustable 5A buck converter. One turns on every time, and the other one only about 10% of the time. I’ve tried adjusting the voltage from 4.9 to 5.2 and doesn’t help any. I’ve switched power connectors between the two M2’s and still the same M2 will only turn on about 10% of the time. Any ideas?

5 amps or 5 volts? 5v 2a (10w) is recommended. Is it connected via USB? I have had trouble with some cables.

I needed a larger converter because I’m running a second M2 and a Raspberry Pi. The converter is set on 5.0 volts. It is one of these:

I’m going to try heavier gauge wires to see if that helps.

Going into the S1 port, not USB.

Hi @kineo,

Can it be powered from the S1 port without a DC-DC converter? Is there any chance you can test that?

Hi Svetlana, I shortened the wires and put in heavier gauge wires and still have problems. The other M2 receiver is working fine. I decided to try the USB power on my computer to make sure it wasn’t something with the converter, and it still randomly will not turn on. It’s very strange.

Sorry if I missed it but have you tried plugging it into a phone charger into the wall? If you plug it into a computer make sure it’s a USB 3.0 port.

Tried the phone charger USB cable and did the same thing. More often than not the M2 does not turn on when plugged in.

Are you using one converter per device (M2, M2 and RPi)? what is the main power source for the converters?

I’m using one 5A converter to run two M2’s and the RPi at 5 volts. This is on a large drone with two 10,000mah 6S batteries. There is a second 5A converter set at 12 volts powering a lidar scanning device.

Yesterday I was able to do a successful flight. The M2 I’m having trouble with took about ten times turning on and off before the orange light finally came on. It did stay on, and I was able to later post process the data with no problem.

It seems the issue might not be power-related, but based on the specs the max current consumption of the M2 is 3A, so in the remote case both units draw a peak current of 3A each, your converter will not be able to provide it.

On the other side, I don’t remember if all the logs are preserved between reboots, but you can check them in case there is any information on them regarding the failed start-up.

I’m measuring less than 0.5 amp with both M2’s and the RPi on. I saw the 3A in the specs, but I haven’t seen anything near that, unless it is for an instant on start up and my meter is too slow to measure it.

Hi, facing the similar issue with a few of my Emlid reach M2. I have connected with a regulator output of 5V, 4A but it failed to start some times. Even we have tested the same using a bench setup of 5V, 10A but still the results are same.

I’ve had the same issues. It got to the point that I opted for a different unit to feed nmea. I could never get the M2 to work as it should.

Hi @kineo, @himanshu.agrawal, @Seth.Z,

Would it be possible for you to share the following data with us:

  • The Full system report from your units

  • The Hardware setup photos

You can email us at support@emlid.com with that since it may contain some sensitive info.

1 Like