M2 doesn´t connect to wifi

Hi, I have an issue.

My Reach M2 always doesn´t connect to the pre-configured wifi networks.

In the field, I use the LTE wireless router.
My Android phone and laptop connect well to the wifi on this router.
I also confirmed that the router had assigned IP address to these devices well.

However, if I connect directly to the M2’s wifi on the router, the ReachView app doesn´t recognize the device.
When I connect to the M2’s wifi, Blue LED starts blinking rapidly on Reach.
But it fails connection, I see the blue LED stays solid.

The distance to the router makes no difference.

And I tried connecting my M2 to another Wi-Fi hotspot - Android phone. But there is no any difference in the behavior.

My ReachView version : v2.22.4

Has anyone solved this problem?

Hi @hwa,

Welcome to the community forum!

Let me comment on the issue below.

When the unit starts the connection to the Wi-Fi, the network LED blinks rapidly. When the unit is connected to an external Wi-Fi network, the network LED should be stable blue. It looks like the behavior you described.

To access the Reach device in the network, your smartphone/tablet with the ReachView app installed should be connected to the same network.

Please try accessing the device via the IP. Just type Reach_IP to the address bar of the Internet browser on the connected smartphone/tablet.

Thank you for your reply! @polina.buriak

And I wrote the wrong name. My equipment was M2, not RS2. Sorry.
Also, I think my test environment was misrepresented.

  1. I have a LTE wireless router.
  2. Turn on M2.
  3. I connect the laptop to Reach wifi. I access the M2 via
  4. My LTE wireless router is searched on the wifi tab of ReachView. I press the connect button.
  5. Blue LED of M2 flashes quickly. However, it is fixed on about a minute later.

From what I saw in Document, if the blue led is fixed, it is Hotspot mode.
It is believed that M2 tried to connect to LTE router, but failed to connect for a certain period of time and moved back to hot spot mode. Isn’t it?

Phone and laptop are connected to LTE routers well, but only M2 is not connected.

And I found something interesting.

I changed the test configuration as follows.

  1. Connect the laptop to the LTE router.
  2. And set laptop to hotspot mode.
  3. Turn on M2.
  4. Connect my phone to M2 hotspot . Run APP and access M2 (
  5. My laptop’s hotspot is searched on the wifi tab of APP. I press the connect button.
  6. Blue LED of M2 flashes quickly. And it slowly blinks soon.

In this way, M2 is well connected to the laptop’s hotspot, and the Internet is also well connected to the LTE router (it is also connected to laptop).
I checked that the position status of M2 is changed to RTK fix.

I wonder why M2 is not directly connected to the LTE router, but responds to the bridge connection through the laptop.

Hi @hwa,

Thanks for the specification!

You’re right, when the blue LED is solid on Reach M2 it means that the unit is broadcasting a hotspot. When it starts blinking fast, it means that the unit is trying to connect to the network.

Can you specify at what band your router broadcasts the Wi-Fi? Reach receivers can work with 2.4GHz networks only.

Also, would it be possible to check the connection with any other Wi-Fi network, for example, your smartphone hotspot?

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.