L2 GPS missing/Header error - Post processing ReachRS2 + pospac Lidar

Hi Everyone,

I am a new owner of a Lidar system. I made my first flight a couple of days ago with my new system and with the Reach RS2 in logging mode. To post-process the trajectory correction of the drone I need the Raw rinex2.11 log. In the pospac software from applanix, when I try to do the “compute RTX” with the .obs I have a message:

Error: Unable to start order! Operation result: InvalidOperation. Error message: Could not read file. Please check the file format and make sure the file is not corrupt.

When I rename the .obs to .19o (like the file provided by the public government antenna) I have a different message :

Processing data : failled

I try also to convert with the RTKLib the ubx file to the rinex file, but the same result than the first error message.

Is there anyone who use pospac who have experience with this software? Any advice or recommendations?

firmware version 2.20.7


M600 Pro
Lidar VX-15 Yellowscan

I think you will get a faster/better answer from Applanix, if you provide them with the rinex file.

Yes good idea, i will try to contact them also.

Tomorrow I will try with the new firmware 2.20.8 ( but I don’t think it will change something, regarding the changelog) and if there is no change maybe with the 2.21.2.

Thanks for your answer.

Ok, I get an answer from the company, it looks it is missing the L2 GPS Records in the raw rinex file… any idea about this?

I attached some screenshots of my conf.

Maybe it doesnt support L2C?

Same “issue” as here?

Ya I saw this post, do you think I should try to update to the dev firmware as explained in the last answer ? It looks it solve some data who are dropped in L2 during the export to rinex…

Yes. You probably should. I’ve had no issues with missing epochs nor L2 carrier phase signals since I updated my firmware.

ok thanks, I am updating now, will see in couple minutes…

Hi Arnaud

RS2 records L2C only, it does not record L2P.
L2C is only available for new satellite generation. While L2P is available for all satellites.

That means: if a satellite is older generation, RS2 only log L1.
Unfortunately, their is still many satellites with only L2P (in such case RS2 does not log L2).

In Americas, where we mostly used GPS and Glonass having a receiver that only records L2C can be an issue since there is still many satellites that do not offer L2C.


what version of RTKConv are you using?

I recently got a response on another thread regarding RINEX conversion for L1 only

Also, I’d like to point out that RTKLib version 2.4.3 Emlid b28 is designed for Reach RS+ and Reach M+ receivers and, therefore, outputs L1 data only after conversion. I assume that’s the reason why OPUS aborted the submitted data.

For Reach RS2, there is an RTKLib version 2.4.3 b31 that can be downloaded from our docs.

Omg I hope it is not this, because I was not expecting to buy another GNSS antenna now…mostly I imagine the minimum price is about 6000/8000$…

I use the RTKLib demo5 b33b2. I saw before the recommendation in the doc.

BTW, I updated my antenna to 2.21.2, and It’s still not possible to post-process the data… I am lost

Hi Arnaud,

May I ask you to share your logs so that we can take a closer look?

Yes sure, this is the logs downloaded directly from the anthena :

raw_202001091539_RINEX-2_11.zip (4.4 MB)
raw_202001091539_ubx.zip (5.4 MB)

How can I know if I have L2C/L2P GPS/GLONASS records in these logs? Because one of the engineers told me there is no record for the L2 GPS, but I am scared if it is the fault of the pospac software who is not able to read the L2C records.

You can convert the UBX in RTKconv, and then open the resulting Rinex file in RTKplot.
Doing that shows no L2C data in your ubx, which is quite odd.

Can you update to the dev software and try a 30 min collection?
On that firmware there are some fixes to L2. (I take it the provided data is not from the dev-firmware?)

Thanks Christian for your message.

My RS2 is already in 2.21.2 firmware, which is the last one. The raw I uploaded above are from approximately 1H20min of observation and from this firmware too.

Btw, in the logging page in reachview, I set up the RAW data to RINEX2.11 directly, but the anthenna, at the end of the logging (when I switch off the logging), it generate two files : the rinex and the UBX. Do you advice to choose only UBX and process to the conversion manually with RTKConv ?

I’ll compare to some of my own logs later.

Personally I like ubx the most. The ubx is the raw file, and with that I can do a lot of manipulation.
Rinex is a processed version of the ubx.

You can compare it to the photoworld. Your camera can shoot raw, you can process that raw to a jpeg. Rinex is sort of the jpeg of the geospatial world :smiley:

You are right, but if we continue to compare to the photo-world, the raw photos are much heavier than the jpeg, but here, the UBX is half size of the rinex file, it is why I am a bit confuse or wondering if there is not a bug or missing data. :grimacing: or I guess it is just a question of compression…

Btw, I was thinking that the antenna is recording directly the raw in rinex, but after taking a look inside the file I saw that the rinex file is converted from the ubx by the antenna.

This my L2 records, it should be usable right?

Hi Arnaud,

Please note that, as Stephanie has mentioned, Reach doesn’t track L2P frequency. It tracks only L2C frequency.

According to your RINEX log, your Reach RS2 has recorded the L2C frequency. I’ve attached the screenshot of the log.

Please check if your software is capable of processing L2C frequency.

Shouldn’t there be entries for GPS for L2C?

1 Like