Invisible Reach RTK Modules in the app

I have two Reach RTK modules bought more than one ago.
I temporarily used them during the last summer in 2017 to check the module accuracy.
Now, I want to use it again for UAV so I attempted to update the firmware of the modules as the first step.
I powered on and then I tried to connect the modules through wifi with my mobile device but the reachview app showed nothing.
I tried to connect them with an internet browser and the app but both failed.
I can see and connect the modules in my mobile device but the reachview app does not seem to recognize them.
How can I get them into the app? Please, help.
Thanks.

You probably need to flash reach with latest firmware for the Reachview app to see it, your reach is running to old firmware.

1 Like

Yes, thanks.
But I question is how I can flash the firmware.
The modules are not working with browser and app.

You dont need the app or networking.
Just download new image and flash reach through a usb cable.
The guide is here

2 Likes

Many thanks, again.
By the way, where can I get the image?
The guide does not provide the actual link for the image.
The download link seems a hashed one that is not in the page.

I tried now and link works fine.
Click on Reach Image v2.9 name

Oh, yes. IE works fine.
Chrome does not work with that.
Perfect! Thanks!

Solved.

1 Like