How to setup static wlan0 IP address on reach M+


I can connect to other wifi networks in reachview app but how do I setup a static wlan0 IP address on the Reach M+ ?

Thank you

When your Reach M+ starts up it creates a Wi-Fi hotspot and already has a static address of

If there is a familiar Wi-Fi network in range, then your Reach M+ will connect to it instead. If you don’t want that behaviour, then move your Reach M+ away from that familiar Wi-Fi network while booting up; or go into the wireless settings and tell M+ to ‘forget’ that network.


Thanks for your reply but this is not exactly what I am asking.

I have a wifi hotspot running that I want to connect to using a static IP address, I can connect to the hotspot in reachview app wifi setting but it uses DHCP from the hotspot, I want to set a static IP address on the M+, I do not mind editing files with vim in cmd line.

Thank you

The simple way is to assign a static IP address to Reach in your DNS server.

Usually something like this:


If you choose to set the static IP on the M+ side, then you need to set the IP and the default route for the interface wlan0.

I’m thinking that you might be able to do that in the /etc/wpa_supplicant config or you might have to get into the /etc/systemd config files. I don’t think /etc/network/interfaces is the place to do it (well, not anymore).

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.