Having multiple issues with my M2

Having issues with my M2 since updating to 2.24.2.

The first issue was no GPS data. I tried 3 different GPS cables that I have with no resolution. I only have the one Multi-band GNSS antenna from Emlid to try with it.

Later yesterday, I could not connect with Reachview. I connected to the hotpsot of the M2 but no device found. I have tried several times and it would not connect. I have tried it with Reachview on a Android phone, Android tablet and an Ipad. I have tried it inside and outside with the GPS antenna connected and clear view of the sky.

Just tried again today during lunch and now when powered up the M2 is only displaying the yellow light. I do not get anything on blue or green.

Any Ideas

I’ve been having issues myself recently. What type of power supply are you using? USB and a brick box or via S1? I have had issues in the past where if it was not getting a GPS signal, sometimes it wouldn’t complete the boot up.

All via usb, while I was at the house, power was supplied by a wall socket phone charger for my Samsung phone. It is a quick charge supply not sure of the stats. I had the GPS receiver outside of a South facing window.

In my vehicle a cell phone charger 4.5, receiver on roof.

Ok that shouldn’t be it then. I ran into issues using a buck converter into S1.

Flashed the unit to 2.22.7 (I had it on my laptop), that brought my lights back. Connected to the Emlid wifi and setup my cell phone hotspot. Connected to hotspot and updated to 2.24.2.

After updating, it took 3-4 tries for Reachview to “see” my device. I knew it was on the hotspot network still as the blue light was flashing slow. Still no GPS data.

Suggestions?

What was your issue with the buck converter? Once I get things running, I plan on using one to power the unit.

I am trying to make it work as a base for Trimble rovers. I want to set it up as a base sending data TTL to an Arduino which will inject message 1007or 1008 and send it out. When I do this I was planning on using a buck converter to power the units. I have some D-Planet LM2596 DC-DC Adjustable Buck Converters to do so. They are adjustable with a 3A max output.

I am using a converter on a raspberry pi and the entire, so I didn’t have the voltage up high enough to supply enough to both. I believe I set it to the highest of the two, which I believe was 5.5v. Then when both pulled voltage and it dropped it was still supplying enough for each.

Thx, I will have to check my voltage output when I wire both the M2 and Arduino to make sure I am meeting specs.

1 Like

I’m wondering if there is a way for you to check the voltage on those bricks you are using. I can’t recall if there is something in ReachView that shows that.

Not sure if there is a voltage input monitor in Reachview or not. I was just going to use a multimeter.

Yeah that would work.

Hi @jp-drain-sol,

Could you please tell me a little more about your difficulties with Reach? It will help me to understand the issue fully, check if it can be resolved remotely, and suggest further steps. I’ve commented on some points down below:

The first issue was no GPS data.

Is there a chance you have another Reach M2 to test with the same antenna? It would help to check if the antenna can be damaged.

I knew it was on the hotspot network still as the blue light was flashing slow.

When the Reach and mobile device are in the same Wi-Fi network, is it possible to find out Reach’s IP in the network scanning tool such as Fing and access it over the browser? Could you please clarify if you connect the receiver to the Android or iOS mobile hotspot?

Not sure if there is a voltage input monitor in Reachview or not.

There’s no such monitor in ReachView. However, you can check the voltage with a multimeter.

I do not have one. A friend almost an hour away does but I have no reason to go up that way at this point.

I re-flashed with these instructions


I flashed to 2.22.7 then went through initial setup and updated to 2.24.2 this corrected the light issue but still no GPS. I have done a continuity on the cable and it is fine.

If I have further issues with Reachview, I will try the browser method.

Hi @jp-drain-sol,

Please check your PM. I’ve written to you there.