Firmware Flash Failed and Overheating

Hello to everyone

While my Emlid Rech M+ device was working properly, when I suddenly turned on the power, only the power light started to come on and the other lights did not come on.
When I try to flash from the computer, I get the Flash Failed error.

Also the device started to overheat after this error.

What could be the reason? (64.5 KB)

Did you tap the Export Logs on the Flasher? If so, the folks from Emlid can answer your question better than most of us.

Yes, the attached file is the log file I received.

Did you also read where it stated to email to

Hi İzgi,

when I suddenly turned on the power

Have you connected a different power source? If not, can you share some additional details on what happened? Also, please send me a photo of your current hardware setup.

If you haven’t tried changing the setup, let’s see if this helps:

  • Connecting Reach M+ to a power bank or a wall adapter

  • Trying another cable

Hi İzgi,

How is your Reach M+ doing? If you’ve tried other cables and power supplies, be sure to let me know about the results :slight_smile:

Yes, we tried with other cables and powerbanks, but likewise, only the power light is on. We cannot update the firmware on the computer.

Hi İzgi,

Thanks for checking! I’ve asked this to see if we can make the device work right away without reflashing. The procedure deletes all the data from the receiver, so we usually don’t recommend it until we try other ways.

Also, this behavior doesn’t seem firmware-related, so reflashing can hardly help here. Please share your hardware setup photos and describe what happened before only the red LED started to come up. I need this info to find out why the issue occurred.

1 Like

The hardware setup was not on a drone or rc plane. We just use it as power from a powerbank leaving it fixed in a certain position.

Hi Izgi,

Kseniia asked for more details about the power source and hardware setup because we’re trying to understand if it’s possible that Reach was burnt out. So, we need to know from which port it was powered, which cables were used (standard or custom), power source specs, and any other info you think may help us.

Usually, it’s not that easy to burn the device, but we need to know for sure. Such LEDs’ behavior points to power issues.

1 Like

Here is my hardware setup. The power light stays on like this. I tried with 8 different usb cables, including its original cable. It stays like this when I power it with 4 different power supplies and the computer.

Hi İzgi,

This setup should work indeed, so we need to dig a bit further to see what’s wrong. I’ve written to you in PM as further troubleshooting can require some sensitive info.

Thank you for your interest, I sent you a pm

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.