Emlid RS2 Modem Issues

So Regarding my post about the Rs2 and my Raven Viper Pro autosteer in our sprayer (which was a huge success in my opinion) we are using an NTRIP caster situated about 17 Kilometers away from our shop at a friends place, when I was testing out the Raven/RS2 combo I was running the correction through the hotspot on my phone which worked great… when I was operating the sprayer. I got a data sim card on our corporate plan and put it in the RS2 and after fighting for five minutes to get the modem to turn on and stay on it worked… For about three reboots. Now it seems that I’m sitting in the sprayer for about half an hour every time we want to spray. The modem won’t stay on after a reboot and I have to turn it on again. The worst part sometimes is that the “cellular data” box with the switch to turn the Data on in the settings is greyed out sometimes and I have to reboot it to get it to the point where I can click the switch again. Any Ideas/Suggestions/Answers?

Yuck. A standalone MiFi is the way to go to connect ALL your devices that need data. At any given time we can run two iPads, a laptop, Reach RS2 or M2, data collector and the drones all on one bill.



Hi Ian,

That is definitely not how RS2’s modem should work. To understand what can be a reason for this, we need to look into the Full System report from your device.

The Full System report can contain sensitive information, so it’d be better if you send it to support@emlid.com

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.