Datum in Pix4D

It’s part of the initial setup. It always comes in on WGS84, but you have to choose the output CRS. Also, make sure the CSV is formatted correctly. Can you share the file?

High the CSV seems to be formatted ok and I can share it. when I put each points coordinates into google maps they show up in the right field. Sorry if its a dumb question but how do I chose the output as CRS?

Also when I use RTKPlot my RMS is E=24.9360, N=46.2513, U=0.8190, 2d=105.0910 could this be down to user error when surveying?

Sorry, CRS is coordinate reference system which is basically just the term for the different coordinate systems whether they be cartesian or geodetic.

That’s some really high error. It could be that the software is recognizing how far off the survey shots were in comparison to the native wgs84 map and not accepting one.

My friend did say the pix4d stated the one of the points was outside the area covered. Any ideas why? I know that the area covered by the drone was a lot bigger then the area covered by the GCP’s.

Hi @sgeyeuk,

Could you please share the CSV file with me as well? I think it’d be easier to figure out what’s wrong.

Sorry it says iam not authorised the upload the file. do you have an e-mail I could send it to?

PS my friend and I think it may be to do with the co-ordinates system used (WGS84 EPSG4326) as pix4d does not seem to like it. I would still appreciate any help you can offer.


Sure. Could you please email us at support@emlid.com? I’ll take your ticket.

e-mail sent.

EPSG 4326 is totally fine. I have a feeling that whatever was used to collect the GCP’s did not have an accurate base coordinate, and judging by the RMS values an accurate survey either. You should find out if the base coordinate was known and manually entered or derived at the time of the survey. These two methods can be vastly different. If the GCP’s didn’t show up where you expect them when uploaded it should have been an instant clue that was easy to see.

Link to bring in a separate, but related post that will be carried on here.

To comment on that post Emlid Reach as well as almost all GNSS receivers natively record data in the WGS84 Geodetic coordinate system. In most cases third-party software then allows for the use of Cartesian and/or local coordinate systems.

Reachview as the native Emlid software does not currently provide the ability to use Cartesian coordinate systems. I believe the number one software typically recommended here is MicroSurvey FieldGenius which has Windows Mobile and now Android versions. I would highly recommend the Android version. In my opinion the biggest advantage to a survey software of this type is the localization feature which basically removes the need for a globally absolute accurate base point in terrestrial surveying, but also allows the use of surface (ground) coordinates which are YXZ that are not a perfect translation of Geodetic to Cartesian.

Accurate WGS84 coordinates are still required for aerial mapping unless you have design software on the backend that can align Cartesian grid coordinates to surface coordinates. In order to be able to use Cartesian coordinates for GCP’s in aerial mapping they have to be grid, or a direct transformation from WGS84.

1 Like

I think i understand that. The emlid units I use only do wrgs84 so not sure what else I can do. It also doesn’t explain why the coordinates in Google are OK but in pix4d there in the sea in Africa

You know what… I just remembered another guy I helped that was in the UK and his longitude was 0 or there about and the lat/lon were reversed in Pix4D. They may be in order in Google Earth by default and the columns are not mapped correctly in Pix4D?

For instance - London is about 51,0 and 0,51 is off the east coast of Somalia.

Not sure what you mean, sorry. This copied from the csv file for the points. long and latt are the right way round. We even tried swapping them just to be sure. 53.80099009 -2.819394899

Look at where you are importing the GCP’s into Pix4D make sure the 50’s value is under latitude and -2 is the longitude.

Hi @sgeyeuk,

I’ve opened your GCPs in the Pix4DMapper and they seem to be in the UK. As Michael said, may I ask you to make sure that you import CSV’s columns in the right order? Could you provide us with a screenshot of the GCP Manager window?

1 Like

Thank you all for your help on this. Lewis managed to sort it. the Default ESPG (think that’s right) was set different to the one used by the emlids. Working fine now. Thank you

1 Like

Hi @sgeyeuk,

Glad to hear you solved this!

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.