D8R-XP Binding

After moving cables and conectors, i am getting something like: No INS backends available

I think I found your problem. According to the photo of your receiver, you did put the jumper on the ground pins of ch3/4, not the signal pins.

Wow thank you :scream:

Now I have this issue. I am using a battery in the servo rail:

I tried to power from a different usb even from the power connector. I changed the usb wifi connector and i got the same error :laughing:

Try a shutdown and restart.
Why did you abort the first start of the Arducopter.elf?

I shutdown and restared couple times… still getting the error, I aborted the first start because I was going to use the 3dr radios as telemetry. I tried:
sudo ArduCopter-quad -B /dev/ttyUSB0
read failed - Success
read failed - Success
read failed - Success
read failed - Success
read failed - Success
read failed - Success
read failed - Success
read failed - Success
AK8963: bad DEVICE ID
read failed - Success

  • Also:

pi@raspberrypi ~ $ sudo ./ArduCopter.elf -A udp:192.168.43.151:14550 -C /dev/ttyUSB0
0
AK8963: bad DEVICE ID
pi@raspberrypi ~ $

I will keep trying…

I unplugged all the servos from the servo rail, even I unplugged the gps antenna and when I run the
pi@raspberrypi ~ $ sudo ./ArduCopter.elf -A udp:192.168.43.151:14550 -C /dev/ttyUSB0

I got:

No INS backends available

@netxingnet

Have you compiled APM yourself? Could you please follow our updated version of installation tutorial.

If you want to compile yourself though, use navio-experimental branch. If the problem stays, please let me now.

Either way, I’m going to have a closer look on AK8963 driver next week. We’re aware of the issue, but it had always gone away after a reboot.

@george.staroselskiy

I followed that tutorial yesterday. I will try the navio experimental in my raspi 2. I think it is something wrong with my raspi B+, sometimes it works great, but lately is just crashing. So I will keep you in touch about the issues.

Thanks for your help, all of you.

Even with the raspi 2 and the experimental navio, I’m still getting the same error, could be something wrong in my Navio+ board?

With the RPi2 you should use the navio-rpi2 branch, not navio-experimental.
I tried it before with the normal raspbian and navio-experimental and got the same error.

@netxingnet could you please try running AccelGyroMag example? Would magnetometer work? This way we can verify that this is not a hardware issue. Please power cycle the board before running the example.

Hi

@schuermannsebastian I meant I tried both with different raspis. Right now, I’m running raspi2 with rpi2 branch. This morning the apm is running.

@igor.vereninov AccelGyroMag runs normally. I woke up this morning and tried the same ArduCopter.elf that I compiled and tried yesterday which did not run, but today it is running… :sleeping:

@netxingnet There is some issue with compass reinitialization, which lately started to occur more frequently, and only power cycling would help to resolve it. This only happens when restarting APM. We are looking into it.

Hello guys. I’m back :blush:

Today I had the opportunity to test the board again without get any results with the transmitter and receiver. I made couple of videos to see if you guys can find something wrong that I need to fix. Thanks

Testing the binding between receiver and transmitter with one servo how @schuermannsebastian suggested:

After I did that, I plugged in everything on the navio and tried but nothing happened(with mavlink the servos run normally):

I am using my Navio with a rover, so I am not 100% sure, but with APM2.x and Pixhawk you have to “arm” the flightcontroller before it is ready to fly.
Since it is the same firmware, it should apply for the Navio, too.
With APM this is usually done by holding throttle down and yaw right for a few seconds. The blinking of the LED should change and throttle should be active then.
This is a safety feature, because fast rotating props can leave nasty cuts or even take a finger off.
Do not google it, you will be sick. :frowning:

@netxingnet Your wiring looks correct, but to make APM control motors you will need to perform radio calibration in APM Planner and then arm the motors.

Can you now see RC values change in the RC calibration window?

I could perform radio calibration in APM Planner, but I’m having problems with accelerometer calibration and compass calibration. I had to ask this dumb question: the back of the raspberry pi where are the usb ports is the front side of the navio+ right? :confused:

In the section of compass, I have 3 options, is it Pixhawk the right one for navio+?
Thanks for your help, we almost arm the motors, couple more post I believe :laughing:

Well, almost there :smile:

Right, we fly with USB ports facing forward.

You don’t need to specify anything there, compass will work by default.

What kind of issues are you experiencing with calibration?

@igor.vereninov

I could calibrate everything this morning… :ghost: Now the problem is an alert: low voltage in the board. I was going to use the Voltage and current sensing steps in the docs section, but I got a bigger power module and I am not sure which option I need to choose in the APM to read voltage. I am using a PM2.5.2 APM2.6 Pixhawk Power Module cable V1.0 Output BEC 3A W/XT60

Max input voltage: 30V.
Max current sensing: 90A.
Voltage and current measurement configured for 5V ADC.
Switching regulator outputs 5.3V and 3A max.
6P molex cable plugs directly to APM/Arduflyer 2.5’s ‘PM’ connector.

As Raspberry has no data about Navio board voltage, prearm check should be disabled as shown here. Pick “Skip Voltage”. This has nothing to do with battery voltage.

Configure power module as shown here and then you can adjust dividing coefficients comparing readings to a voltmeter. Navio+ as Pixhawk has a 3.3V ADC, so your maximum range should be divided by 5/3.3 = 1.5 , so only 20V max voltage and 60A max current.

@igor.vereninov and @schuermannsebastian Thanks.

I armed the drone today… :cry: I meant, We armed the drone haha :smile: 3 servos run normally, but the fourth i need to move the throttle a little to make it run. Not clue, what is happening… Also when I am moving the throttle around I can see that that servo sometimes stops even with the throttle is in a high level…