Connection over Bluetooth to 3rd-party device

Hi Pete, I have just bought an RS2 and am struggling to pair it up with 12D field on a windows tablet.
May I ask what settings you used for the correction data transfer?

I have got NTRIP corrections working correctly in the ReachView App, and have tried various output corrections (including BT, via an NMEA string - which I would think should be the ideal).

The RS2 is paired to the tablet via Bluetooth, and 12D field seems to connect to it, but I keep getting an error “Sending Error 111” in ReachView (corrections output), and a confirming error in 12D Field “No NMEA is being recieved…”

Any help would be much appreciated!

Which version of 12d are you running? The latest version has a new Bluetooth interface which fixes a lot of the previous issues when connecting.

Following doco for V14 prior to new Bluetooth option.

Following doco for V14 c2f with new Bluetooth option.

what is the way to connect for version 9.0

That version is about 11 years old so may not work with modern Windows version running 12d. I recommend you update…FYI I am a 12d Survey trainer and Surveyor using RS2s with 12d field

1 Like

This is great Noel, thank you very much.

I am currently running 12D Model 14.0C2c, but would be happy to update if needed.

Have you been able to set up an RS2 with NTRIP corrections?
We generally try and run SmartNet instead of a base station.

Thanks again, Hugh.

Hi Hugh,

I both resell Smartnet for use with Emlid hardware, and regularly use HxGN Smartnet with Emlid RS2 hardware myself (less so with RS+ these days, but extensive use with RS+ in the past).

I really appreciate all the features available with the Smartnet subscription, including GDA94 and GDA2020 RTCM feeds, in both nearest base and VRS modes. Smartnet also offer great post-processing and coordinate conversion tools within the web console for Smartnet, along with RINEX download for post-processing.

Please let me know if you have any issues getting up and running.

NB. Tip #1 - load the IP address, rather than the url for Smartnet. You can find the IP address on the top RHS corner of page 2 on your Smartnet subscription certificate.

Regards, Alistair.

Thank you Alistair, I appreciate the help.

I have managed to get SmartNet corrections working with the RS2, which was quite seamless surprisingly.
Have you had any feedback or experience with regards to outputting these NTRIP corrections to 12D Field?

Hi Hugh,

I was communicating with Noel about this over the last day. As Noel is a 12D Survey Trainer and surveyor regularly using 12D Field with RS2’s, I can’t top his wisdom and experience with 12D!

If you’re running an older version of 12D Field, I can’t guarantee 12D Field will integrate. I think it is advisable to upgrade to V14 c2f or later.

I see Noel from @detailsurvey has posted some setup guides in this post - kudos to Noel for putting these together.

Following is link to video setting up RS2s to communicate through Entrip via YOUCORS caster

I tried a few of the Entrip casters but YOUCORS seemed the easiest to set up. You can get a trial licence and once happy with the setup reasonably priced plans are available

This is good Noel, thank you very much.

I may have come across a little vague, but I’m currently using SmartNet as our CORS caster, and its working ok for giving me a Fixed Solution.
Ill check out YOUCORS as an alternative to SmartNet though also…

My current issue is: Sending these corrections out of EmlidReach, and into 12D Field.

Would this be done by outputting an NMEA string from EmlidReach via Bluetooth?
I have tried a few configurations but I keep getting a “send error 111” message in EmlidReach.

12D Field seems to acknowledge the RS2 reciever, but gives an “Error receiving NMEA from device” message, and thus it won’t compute a fixed solution.

Huge Kudos to you Noel, any further help would be much appreciated!


I just did a video that may help that shows RS2 linked to 12d field with corrections via ntrip

Thank you Noel, this is perfect.

I am now having issues connecting to NTRIP caster via SIM card/Mobile data.

Last time I had RTK Corrections working I was using home WIFI (which was an oversight), but now it wont connect to NTRIP when using the sim card/mobile data.

I have tried the SIM card in another GNSS unit and I can confirm the sim is active, also Reach View shows “Telstra Mobile” in the top RHS of the screen (which I assume tells me its active and connected to the internet?)

Do I need to have Mobile Data turned on in Reach View?

My “correction input” page currently has the following settings configured:

  • Address: (SmartNet)

  • Port: 12101 (the additional 1 at the start is intentional as per SmartNet)

  • Username and Password as per our account (checked and OK)

  • Mountpoint: No mountpoint list is being displayed as a drop-down menu. When I connect via home WiFi, I get the mountpoint list and NTRIP connection works…

  • Format: RTCM3

  • Send GGA messages: Box is ticked.

Thanks again for your help so far Noel. Any help with this issue would be very much appreciated.


Hi Hugh,

Yes, to connect to the Internet via the built-in cellular you need to enable cellular network in the Mobile data tab.

Have you checked if you can see the network bars and the connection type next to the battery icon?

You can check our guide on how to connect Reach to the Internet for the detailed explanation on how to enable the Internet connection via the SIM-card.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.