Connecting new Reach RS+ and M+ to WiFi

How to connect the new REACH RS+ or REACH M+ (Reach) to a Wireless Network 802.11 (WiFi)

Reach (App 2.14…) can not get a wireless connection to a FRITZ!Box 7490 (OS 6.93). This device is currently the most common SOHO router in Germany.
Solution: Use an alternative Wifi base station and connect it with an Ethernet cable to the Box. Here a ten year old Speedport W501V worked like a charm. It is also from AVM, the leading manufacturer in Central Europe.

If Reach knows a Wifi Network and this network is on air, then Reach tries connecting to it forever. Even if these tries fail every time Reach does never fall back to its initial Access Point mode – until Reach is rebooted. If Reach knows more than one network, then the risk is high that networks which once gave a successful connection are not selected.
Solution: Delete all unsuccessful networks from Reach and switch all other Wifis off.

Reach does not connect on the WiFi channels 12 and 13 in the 2,4 GHz band.
Solution: Select appropriate channels on your home Wifi.

Reach will not answer DNS requests for http://reach.local.
Solution: Use when on Access Point Mode. When Reach is connected on Network Mode, try http://reach.[], for example

The native Reach Apps for iOS or Android complicate things and may mask some errors. If the name solution shown in the point above fails in your network, try this
Solution: Use the web interface of your router to find Reach or run the command nmap -sP []/24, for example nmap -sP

Mismatching encryption systems or password typos may hinder a wireless connection.
Solution: Use an unencrypted network for the first steps. Updating Reach is possible over an open connection.

After an update Reach changes the encryption checksums for its own Access Point mode WiFi and for the known WiFi networks.
Solution: Reestablish the WiFi connections after an update and set the encryption keys again in your device (emlidreach for Access Point mode) and in Reach (yourkey for Network mode).

1 Like

I also have a lot of connectivity issues with my RS+.

After feeling inspired by your post, especially #3 (which I can confirm), I tried quite a few thing on my router wifi settings. I run a Synology RT2600ac router.

Here are my findings:

  • Use the combined WPA-PSK/WPA2-PSK setting, not the WPA2-PSK only setting. Which is wierd, because looking at the link from the RS+ after successful connection, it indicates WPA2-PSK.
  • Setting MU-MIMO must be set to off. Quite unfortunate for the rest of devices on the network, as disabling this feature makes the network latency slower
  • Your #2 point I can also confirm, and basically makes having multiple SSID’s saved a huge problem. I removed all the remaining, and combined with the above, I could connect.

Hi @Hbb,

Really appreciate you sharing such full report.
We’ll look into all of these issues.


One more report on this one:

  • Apperently the Emlid units don’t like spaces in the SSID’s.

Had been having troubles connecting to more or less any wifi the past week. It then dawned on me that all my wifi’s had spaces in them, deleted, reconfigured the RS+ units, and both base a rover unit jumped right on. Will try some more reboots etc, but seems to be one more exception for the RS+ wifi module. Doesn’t seem like it heard of wifi standards…


Hi @wizprod,

It’s not common behavior.
I’ve just connected Reach to my mobile hotspot with e m l i d 1 name.

Do you use CHG i7p name?
Can you try e m l i d 1 hotspot name?

Also, you can Forget all networks in hotspot mode and try to add them once again.

Let me know about the result.


Yep, Will try it out.

The most frustration comes out of is the lack of trust in the units. Taking them out I don’t if I need to spend 1 minutes setting them up, or 2 hour troubleshooting :confused:

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.