Can't connect to router after v2 beta flash

I flashed my reach using the v2.1 beta file. The update completed successfully and I see the new reachview app when restarting and connecting to the reach via its self generated wifi link. I enter the connection info for my wifi router and hit save. The screen shows the router info, but everything below if greyed out. If I reboot, it goes back into self generate hotspot mode and I can not get the reach to connect to my router.

What am I doing wrong?

Clear cashe or run safe mode/ingongito mode on your browser. Reboot and run again.
Verfi you flashed successfully.
Also, what versiondid you flash from?

@TB_RTK How do you tell which version of the beta you are running? Is there a version file in the ReachImage_v2.1_beta zip? Do all links point to a central file? I’ve been trying to update (four days) and get reach to connect to my wifi without success.

Also, how do you verify successful flash?

Sounds like a problem similar to mine.
Try download beta version again
Or here ReachView beta v2.1.5 update

At the bottom of Emlid menu (where you save wifi credentials) you can see current and new version to update)
To verify a successful flash? Im acctually not sure what i was thinking. I guess if everything works, its successfully :flushed:

Did you hit the added network for a second time? After you’ve added you also need to click it to connect.

I wasn’t able to try it a second time. It tried to connect the first time, reach flashed Blue a couple of times and then turned green and was not creating it’s own hot spot. So I couldn’t get to the app a second time.

I have to try my testing again. I received false negatives I believe. When I did connect to my android mobile hotspot it worked fantastic BUT, the LED was Green. I thought Green meant it created it’s own hotspot so it is possible I missed it connecting to my local network. I was looking for a Blue LEDs to indicate it was connected to wifi.

I still believe there is an issue connecting to my in home wifi. (Belkin 1750AC) Either there is an incompatibility with my wifi or Reach is not providing what my network needs for it to connect. I would see it in the router logs but when scanned with Fing and Zenmap it was listed but no ports were open. It was also never listed in my networks connected devices.

In the beta version the led statuses are much simpler as we didn’t get the chance to address them properly yet. The green in the end simply means the app started with no problems. If, for some reason, it fails, the light will turn red.

The network status can be read by checking the led during boot. During Linux boot it’s magenta. Then it turns off for a second and we start our self tests and preparations. Yellow blinking means Reach is looking for a network to join. Right after that, the led blinks either blue or green, meaning it has connected to a network or created a hotspot correspondingly. Then, the time sync begins and magenta is added to either blue or green for a short period of time. As soon as the time sync is finished, the app launches with a solid green.

It seems, that in your case Reach actually connected to your network.

Could be that I have the same problem. I had no success getting the Reach up and running at work (corporate WiFi, Windows 7, Internet Explorer) or at home with a Belkin N300, Windows 10, Firefox setup. I finally got it after updating to the Beta 2.1.5, using my iPhone as a hotspot and opening the app in Safari. Now the Reach works fine on its own hotspot, but no luck on my Belkin network. It seems to connect OK, shows up with an address in Fing, but I can’t connect or ping it. Anything else on the Belkin network pings fine.

1 Like

Yes. I can concur with your findings. We are not able to connect to a WiFi router. I replaced my Belkin router yesterday with a new router (Netgear,Nighthawk AC1900) thinking it was a problem with the router. It is not a problem with the router. Reach connects and can be seen on the router but when doing an intense scan plus all TCP ports with Zenmap and there are not any ports open. There is nothing to connect to on the Reach. When doing the same scan when using Reach’s hot spot ports for Http and SSH are available. .

I am not familiar with the subject, but is there any chance there are some security settings interfering with your connection? Maybe you can try using a wpa2-personal network?

Both networks I tried (at work and at home) use WPA2 personal security. In another week or so I’ll be getting a new setup (changing from ADSL to the new Fibre-optic National broadband), maybe that will make a difference.

Oh, and Merry Christmas Egor! S Rozshdestvo. )

It doesn’t make sense the ISP would be an issue. The router it is connecting to though might. I to have primarily used wpa2-personal and although the router says connected when scanned with zenmap and fing, both reports show there are not any ports available to talk. Port 80 (and maybe 22 for SSH) should be available. I have tried all of the security settings without success. I can consistently connect to my mobile hot spot but cannot connect to a Wifi Router.

Here is where it connects and is up in router attached devices.

Cannot find with browser

Zenmap scan. No ports

At this point it is connected to the router but there is nothing to connect to (as far as open ports(i.e.80)

I agree it’s not an ISP thing per se, but having a new modem/router and new setup configuration might make it work without ever finding what exactly in my current router configuration is causing the problem.

I’ve tried forgetting the network and starting again a few times with the same result. The procedure is a bit painful, because the Reach ‘thinks’ it has found a known network and locks on, so to get to the app I have to shut the network off first.

Is there a way that the network connection can be tested with a wired connection to the laptop? I have Linux on another computer but I’m certainly no expert.

@egor.fedorov , Could this be a problem with Region settings for the Wifi router? My region settings are fixed in the Wifi Router for North America. Reach does connect to my Wifi router but there are not any ports open to connect to from other computers.

Could it be the web server and SSH on the reach do not get started?

Is anybody in North America connecting to reach via Wifi Router? Not mobile hot spot but Wifi router.

Reachview 2.1.6

Have you tried open ports on router? Disable firewall on router if got that.

You also might wanna try different channel. Most likely its set to auto.
Begin with at a lower channel like 1, 3 or 6 , and a channel that not everybody els is using
More about Eu vs US channel here

Maker sure you dont have an IP conflict, (two devices with the same IP)

Use both WPA Algorithms, TKIP+ AES

UPnP activated

you might want to download the image again and reflash reach;
north american difference for wifi is only a lack of channel 13 - which shouldn’t be an issue;

after connecting to your router -if still not working - use “fing” (app) and do a port scan from your phone connected to the same hotspot; (and post your output!)

Have you tried open ports on router?

No blocking or filter on router. I also replaced the router.

Disable firewall on router if got that.

Yes. Done.

You also might wanna try different channel. Most likely its set to auto.
Begin with at a lower channel like 1, 3 or 6 ,

Good idea. It is currently set to auto.

Maker sure you dont have an IP conflict,

I have not seen this. But, I could try turning off other devices, rebooting the router and try connecting again.

Use both WPA Algorithms, TKIP+ AES

Will try again…

UPnP activated


Thanks @panky I will try manually setting the channel to a lower channel to see if it works. This may be the issue.

after connecting to your router -if still not working - use “fing” (app) and do a port scan from your phone connected to the same hotspot; (and post your output!)

I have done this and the screen shot from zenmap is above. fing reports the same way. No ports open but assigned an IP address. and status ‘up’.(see above)

how do the ports behave when the hotspot is being created?

how do the ports behave when the hotspot is being created?

They are open (and respond on 21 && 80) when connecting to a mobile hotspot and when it creates it’s own hotspot. Just not available when connecting to any of the wifi routers I have tested.