Emlid

Community Forum

Can't Connect To iPhone Hotspot?


(Austin Hill) #1

I posted about this in the 2.1.5 topic, and andrewyushkevich responded that they couldn’t reproduce my problem and I should wait to see if it resolves itself after the next update.

I’ve now updated to 2.1.6 (though I am not sure there actually was a wifi change with this, yet) and my problem persists. I suspect I am making a blunderous mistake somewhere. I didnt want to clog the 2.1.6 thread with this.

I can’t connect my reach to my iPhone hotspot. Every time I try to get reach to connect to the iPhone hotspot it fails and goes back to creating its own hotspot. I can switch over to the reach hotspot and tell it to log back into my apartment router, which it does.

I think I’ve typed in the network name exactly as it appears in the iPhone (see below), checked the password, and selected wpa2. Any ideas what I can try to make it connect?


ReachView 2 beta - connection problem
#2

Try not to use wifi credentials such as `%¤#"&/and so. Keep it simple as it might be a conflict there.


(Andrew Yushkevich) #3

Hi Austin,

The problem is that you can’t connect to hotspot of your iPhone, because it turns off when you connect to wifi.


(Austin Hill) #4

TB_RTK, I would but unfortunately iPhones do not let you do that. They will always be “XXXX’s iPhone”. You can change XXXX but you cant change “'s iPhone”

Andrew, what do you mean it turns off when you connect to wifi?Which turns off? The reach? But it successfully connects to my local router. And I can successfully connect other devices to my iPhone hotspot.


(Austin Hill) #5

So thanks to a helpful note via PM, I see that in the latest iOS, the entire name of the phone is the SSID rather than XXXX + “'s iPhone” and my phone was named “Chad’s iPhone”. So I changed my iPhone to just be called “chad”.

This did not help and now I’m having even more problems:

I had been telling it to log into my iPhone hotspot, it would fail and then relaunch its own hotspot. I could go into the reach hotspot, and either tell it to log back on to my local router, or try the hotspot again. BUT after a few attempts to get it to log on to my hotspot, I am now not able to get it to log onto my local router either. NOW if I tell it to log onto either my local router OR my iPhone hotspot it does NOT connect to either but it does not successfully relaunch the hotspot. I can confirm that it has not actually logged on to my router by checking in Fing that it doesn’t show up. If I unplug and reboot the reach it WILL relaunch its own hotspot, but it won’t connect to the router that it was successfully connecting to a few minutes ago. I have deleted and re-entered all the wifi entries and tried the alternative SSID for my router. No dice. Reach is now not connecting to any wifi AND doesn’t revert to its own hotspot when it fails to connect.

This was proceeded by an apparent glitch in the wifi screen. One of the times I entered the iPhone hotspot info, it did something weird where after I added the info, it showed up in the wifi list as something like “unknown” with Open security. That entry seemed to resist deletion but did end up being deleted eventually (after pressing the X button several times and refreshing the screen).

Am going to try to reflash the reach.


(Austin Hill) #6

I reflashed to 1.2 and was able to log right into my iPhone hotspot. Will see if the problem persists when I re-upgrade to 2.x


(Austin Hill) #7

So It IS a problem with the beta??? I reflashed to 2 and once again couldn’t log into my iPhone hotspot?!?

Since I wanted to try going mobile with my reach on on a pole attached getting NTRIP data over hotspot and forwarding to a GIS program to record points on a tablet, I am going back to 1.2 for the moment.


(Chris eastaugh) #8

I had trouble with mine until I did a ‘reset network settings’ on the iPhone. After this is simply shows up as ‘iPhone’, without any name. Now, it all works fine in 2.1.6.


Smartphone hotspot
(Austin Hill) #9

Well, i was tricking myself and also maybe understand now what Andrew was saying.

Reach apparently won’t connect to the iPhone hotspot if the iPhone is currently connected to wifi. If I first logged on to the iPhone hotspot with my tablet or laptop, then the reach would log in to the hotspot. But if I was not logged into the hotspot already, reach would not log on. When I rolled back to 1.2, I happened to be connected already to the hotspot, so reach connected. I have now re flashed and upgraded to 2.1.6 and all is working over the iPhone. Now I can be fully mobile.

Thanks everyone who helped!