Cannot update from v1.2 to v2 beta

I have tried to update from v1.2 to v2 beta and failed. I can downgrade but I am concerned that this is not as stable as it should be.

I am using a windows 10 pro machine with the Intel USB drivers installed from the Edison setup utility v2016.2.007.
I have used the setup utility and I have also tried using flashall with the results showing most of the update fails due to DFU signature failures (dfu_util V0.9) both on upgrading and downgrading.

When it is working it shows ReachView v 0.4.9 and Reach 1.2. After upgrading it does not boot beyond the steady purple LED.

Does anyone have any advice?

Quick Update…

Some success. I tried using a powered hub and the download reported success as far as the first reboot.

And Failure… It never came back from the reboot though. No USB presence at all. No ability to rerun the batch file

Update: Somehow the USB hub got tied up - not a power shutdown but it would not communicate.

Update2: SUCCESS. After several USB hubs and various cables my tentative conclusion is that the current drawn by the reach is right on the limit even for some USB3 ports. Ive seen no comms, intermittent comms and reboot cycling while trying to update to v2. Finally I have found a PC which seems able to satisfy the Edisons requirements for a stable connection.


I am not sure if this matters at this point, but there are a couple of things to be aware of:

  1. Did you install Intel’s Edison drivers?
  2. Sometimes low quality or broken cables interfere with the flashing process
  3. You can not reflash with a USB3 port
  4. Reboots and all that is OK, it’s how the process goes

Egor, Thanks for your points.
I have now managed to update two reach devices - worth a follow up on what went on.

  1. The version 2 GUI is great. Much easier to navigate once you get used to it. It was probably worth the hassle of the upgrade.

  2. The update process seems to require a very high quality USB connection. While I have had no problem with other devices on the ports and cables I initially used I had to resort to a very short cable (<50cm) and remove all other devices from the hub (such as wireless keyboard dongle) before I could repeatable update the devices.

  3. I’m a windows user and I much prefer the flashall.bat CMD window to the edison GUI for updating. I had succeeded in updating to version 1.2 using the Intel supplied configurator but never to version 2. Even with exactly the same configuration of cables and USB ports the GUI says it has succeeded but the reach is not usable. If flashall shows it has downloaded everything successfully it works.

  4. The edison wifi hotspot is one of those annoying devices which refuses to connect to some devices. I could connect my android table to the reach hotspot a few weeks ago, since trying to update to version 2 beta it refuses to connect even if downgraded to version 1.2 again. I have tried 2 android devices and 2 windows 7 laptops all with no success but a windows 10 PC I have at home works. Go figure! (as a wifi client I’ve never had a problem with the reach).

  5. The USB RNDIS driver is a lifesaver. (4) above would have been the last straw if I had not been able to get a stable network connection through USB. I would recommend it above the hotspot for configuring after an upgrade.

Nick, thanks for the feedback!

  1. Thanks! We are working on more features atm
  2. I am not sure, as I’ve only rarely experienced the cable problem only once or twice. Users, however, report it a little bit more often. Normal phone cables should work with no hassle
  3. Good to know. We don’t usually use the GUI either, so we need to test the beta image with it.
  4. Most devices will not show they are fully connected, as Reach does not provide Internet access. Most Macbooks, for example, will have the wi-fi icon moving, like it’s still trying to connect. But in fact, you are already connected and the app is accessible. Try to check your IP address, if it is in the 192.168.42.XX range, you are in.
  5. It’s really hard to provide a good way to access a device with no physical interfaces whatsoever. Bear with us, we are trying out best :slight_smile: