Can only get small baselines FIX RTK and PPK

Hi All

I’ve been having great difficulty obtaining a FIX Solution with our 2x RS+ in base and rover setup for both RTK and PPK processing. I’ve delved into the forums here looking for solutions, but so far, haven’t gotten anywhere. However for this post, I’ll delve into the PPK side of things, as if I understand how to correct that, I might be able to correct it in RTK mode as well.

I’ve attached a small job which I’m trying to get a FIX for only a handful of GCPs. Base is setup over unknown coordinates, all we need is the relative measurements.

The RTKPLOT views of the base and rover constellations look great - very little cycle slips etc.
Rover


Base

I’ve attempted using RTKLIB to PPK the solution to get a FIX. Settings used are:


However the results aren’t great - only 17% in FIX -

Can anyone see what I’m doing wrong and point me in the right direction pretty please!? This is a constant problem across multiple projects.
Log files at following directory
https://1drv.ms/u/s!AggP_u1axa_ei48IXgFFuhoFNha2_g?e=7OaqHm

Cheers
rtfraser86

Hello Fraser,
here I get 92.8% Fixed
Just need the antenna height of a Base and Rover.
I will make a video and post it here…

Also this cut may affect the solution :

2 Likes

That looks awesome. If you could post the video that would be greatly appreciated.
Base height =1.55m
River Height = 2.06m

Hello Zinou, that signal cut in the rover is very strange, it is as if it had been turned off. That makes you lose the initialization. It happened to me at the base with RS2 but then the problem was solved by emlid. This ppk is after doing an rtk by lora or ntrip?

@agrimgalina Hello Luis,

Yes I see but with RS+ I think it’s something else, it happens when we change parameters like RTK settings (choice of satellites …) for example and we apply these changes then the receiver resets again in this case I advice to choose all the parameters and apply them before to enable logs recording.

Yes you are right for that I PPK with RTKLIB choosing :
Settings1 > Filter Type > Combined (Forward + Backward)
in this case Backward can help to improve a solution.

I don’t know but it is not very important since I will be doing PPK.

@rtfraser86 here is a video :

@Zinou Zinou! In theory those cuts have to be due to some change in the rtcm3 parameters, but I had the same problem with the base after half an hour of measurement. It is already fixed in the new updates. I process PPK in Continuous and Combined. The GLONASS constellation has remained in time, it is time for the Beidou. your video very good. Today I updated my RS2 to the stable version 2.22.6 and the tests in the field were more than good “excellent”

@agrimgalina I made a Logging raw measurements for 9 hours and 20 minutes without interruption and I did not have any kind of those cuts.

Thanks for infos and I’m happy that everything is working fine for you :wink:.

1 Like

Thank you heaps Zinou - I am in the field at the moment and away from the computer but I look forward to checking my settings against yours to see what is different (and then changing to yours).
Like you said in a previous message, the gap is because of changing RTK settings.

Hi Reece!

We’ll also process your data and get back soon with the results.

1 Like

Thanks Kseniia - I look forward to seeing the results

Hello Zinou - after getting back in the office, I’ve tried processing the data files with your settings but I’m only getting about 41% FIX. I have quadruple-checked my settings against yours and I’ve got the exact same ones Furthermore though, your track file doesn’t plot anything like mine. Is that from another project?


Otherwise, what version of RTKPOST are you using? I’m using 2.4.3

Hi,
it’s like yours above with 17.4 % Fixed.
data link :
https://1drv.ms/u/s!AggP_u1axa_ei48IXgFFuhoFNha2_g?e=7OaqHm
I use v.demo5 b33a like a video above.

Hi Reece,

I’ve processed your data and have a few fixes as well. We’re already working on the issue and hope to release the fix soon. I’ll reach out to you once it’s released.

For now, you may use rtklibexplorer’s free software to process the data.

Hi Reece,

We’ve released a new RTKLib QT version with a fix. You can download it from our docs and process your data there.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.