Can not achieve status "Fix" with M+ and RS+

I am using RS+ as base and a M+ as rover. My M+ is on an robocar car. I hope to use Emlid devices to navigate the car. It is important for me to have 1-2cm GPS accuracy.

When I test the accuracy of the Emlid device, the setup is like this, the distance between M+ and RS+ is about 1 meter.

I then setup the base as below


Then setup the rover as below:

There are two problems:

  1. The status is always float. Even after about 30 minutes, it is still “Float”
  2. The baseline distance is about 7 meter. But it should be 1 meter.

How can I fix it?

Thanks,

1 Like

Hi @AutoCar,

Welcome to our forum!

I’ve noticed that you’re working on the v2.22.3 firmware version. We recently released the v2.22.4 stable update with some improvements on RTK performance. Could you please update your devices to this firmware version and check how it works? I believe it should resolve your difficulties with getting fix.

To update the devices, you should connect them to a network with Internet access. The following guides will be of help here:

Please keep us posted.

First things I would try is raise your base and the antenna on the RC car. The type of electronics and materials in an RC car could potentially affect GNSS reception. The base being that low you are probably only getting satellites above 20-25 degrees and the ones that it is trying to get below that (if you have the default 15 degrees) are going to be trouble. Additionally I would cut GLONASS.

We also need to see the screens for RTK settings, rover Correction Input and the Base Mode.

Just curious, what kind of car is that? I have been racing many different classes on and off for about 25 years…

1 Like

The car is Traxxas Slash 4x4

2 Likes

Only thing I see different from my setup is I use 16dbm output and 18.23 kb/s data rate. Also, if you are going to use GLONASS then GLONASS AR Mode should be on. I would try GLONASS of, but I would also try GPS only to see what happens. That should rule out 90% of the settings issues unless it is something in the firmware.

Recommending getting the base off the ground remains and can you relocate the LORA module on the truck? Could be some radio interference with the receiver from the RC?

Are you able to get a fix with the M+ setup off of the car?

1 Like

Hi @chascoadmin

Thanks for your post. Will try 16dbm output and 18.23 kb/s data rate and removing GLONASS. Can you explain what these two numbers mean?

My RC is a kind of autonomous car which is driven by an Nvidia computer. Therefore, the receiver is not needed and was removed. I can relocate the LORA if still needed.

As for base off, I do not have another tripod at this moment. If the base height is a problem, then is my M+ height also a problem? It is about 20cm above the ground at the same level as my M+ antenna. Do you think my M+ signal SNR is low?

Overall, I am very disappointed in this device. I already spent a lot of money and time on this, but was not able to get a “Fix”. Without cm level accuracy, this is useless for me.

NP. Changing the output power can sometimes help when the receivers are in close proximity. Full power is really only necessary in very congested environments and over long distances.

For the Air Data Rate there’s no reason to run anything slower than 18.23 kb/s unless your configuration hits a limitation in the processing of the product itself. The faster the transmission then the less time that transmission is in the air and susceptible to corruption.

As for cutting off the Russian GLONASS constellation, it’s just a recommended attempt from personal experience. Ever since experimenting with the Reach products we have had issues off and on with the GLONASS constellation L1 channel. We were constantly wobbling between a fixed and float solution or sometimes not being able to get a fix at all. It wasn’t until I started running PPK that I noticed that the GLONASS constellation quality in Central Texas was very inconsistent and there were allot of reports of high SnR and outages. Of 8 satellites tracked maybe 4 were a good connection for the entire survey (drone flight). This made me wonder what the quality was with our Topcon equipment so I did some logging and testing and was pretty much getting the same thing of about a 50% success/failure rate in terms of sustained quality. We now substitute Beidou for GLONASS, but it is really a survey by survey basis when looking for the optimum configuration. It’s good to have a good GNSS satellite tracking app so that you can see what satellites are at 15-degrees and above the horizon. If a constellation has 8 satellites visible and only 3 of them are above the usable mask elevation then it may be better to run without them. You can also see this on the status page in Reachview, but I have found that graph to be erratic and not very reliable. Here is my sky plot right now. Note how all the red satellites are low in the horizon… https://www.gnssplanning.com (Detect your location on the settings page and then go to sky plot.)

The higher the antenna can be the better. Understandably the RC’s antenna is desired to be lower and you appear to have a good ground plane so it may be what it is. You might think about some kind of insulator material to cover all the other electronics.

You need to get better SNR on your rover by shielding the M+ better, by elevation of the antenna, and by improving the groundplane.

Can you provide us some pictures of the rover setup ?

Thanks! Some input:

  • Make sure the Groundplane is level. The groundplane (among other things) protects the antenna from multipathing reflected from the ground.
  • Increase the height of the antenna. Preferably with a rigid, but dampened mount.
  • Shield the M+ unit from EMI from your electronics below.
  • Power the M+ unit with noise-free power, or from a separate battery.
3 Likes

On my M+, which is the rover, should I select the same satellites as the base?

Yes, please make sure you have the same GNSS selection on base and rover.

You can get the recommended settings from this video:

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.