Can no longer connect to RS2 on University WiFi network

Before creating a new thread please refer to Quickstart guides for Reach and Reach RS.

In case you are creating a thread about an issue it is necessary to provide following information to get help:

  1. Firmware v28.2 and ReachView 3 v 7.6.

  2. System report. System won’t let me upload b/c I’m a “new user”

  3. Detailed problem description % 4) Your step by step actions:
    Can no longer connect RS2 to University WiFi network. We own 4 RS2’s. Since receiving them a year or more ago, I have had no problem using the standard Hotspot->Configure WiFi Settings_>Connect to same WiFi network “dance” to get the RS2’s on our University wireless network for use on campu (I use my phone as a hotpsot when off-campus). Recently (post firmware update?) I have been unable to do so- the old configuration for our wireless network is gone, but when I search for networks it shows our but with the wrong security type (says WPA2-PSK, ours is MSCHAPV2/PEAP). Of course I can’t put in the required username under this security type. So if I use connect to hidden network create a new network with a more correct security type (Using WPA Enterprise, which I believe is PEAP), it allows me to put in the required credentials and when I click “connect”, it seems to connect to the network (led on RS2 turns blue). But when I connect my mobile device to the same network, I can’t see the RS2. Reachview 3 will simply not find it. I’m not sure if the problem is that there is a 2nd redundant SSID in in RS2 for the same network w/ the wrong security type (but no password), but RV3 will not let me “forget” the bogus one- only the one I created myself. The only way I can keep the RS2 from automatically connecting to the inaccessible network when turned on is to take it off-site or put it in a metal cabinet when I fire it up. Very frustrating.
    AFAIK the uni wireless network has not changed in the last year. I can connect the RS2’s to other networks (including my phone as hotspot) w/o issues.
    I hope someone can help with this. I’d be happy to provide more specific information regarding our campus WiFi network via DM.
    Thanks,
    -pat

  4. Picture of the setup and connection scheme.

  5. If using any additional hardware please provide exact make and model. N/A

Hi Pat,

You might try the Fing app on your phone when everything is connected to the campus wifi to verify that the RS2 is indeed hooked up to the network as the blue LED is indicating.

I can’t help with the network security type question.

Thanks Dave-

I’ll give Fing a try. Hadn’t thought of that!

Hopefully someone from Emlid will be able to comment on why Reachview sees my network as WPA2-PSK instead of MSCHAPV2/PEAP, or tell me how I can force it to forget the incorrect SSID.

Was the network always PEAP? Ever since 2019 when we got our first Emlid units, I was never able to connect to our university network which is PEAP. There was simply never the options to specify that type of protocol in Reachview.

Maybe check with IT if they changed the network protocols.

1 Like

Thanks Gabriel_C-
AFAIK it has been PEAP since before I got our RS2’s, but I will check. I recall having to use trial and error to find that WPA Enterprise (which says “uses PEAP” or somesuch) was the only security type that allowed both username and password credentials to be entered. I could be remembering incorrectly about the past, but I know I was able to connect before, and can’t now. I will inquire with our networking folks to see if they changed to PEAP recently, but I don’t think that’s the case. I wonder if it also might be a certificate issue?

Well, Fing reveals that although the blue light on the RS2 suggests it is connected to our Uni WiFi network, it really isn’t (or at least doesn’t show up in the list of connected devices). If I use another known good network, I can see the RS2 in Fing, listed as an “AMPAK Technology” device and confirmed via MAC address.
I have seen similar behavior (RS2 indicates it is connected but can’t see it on network) with our “Guest” WiFi network, which has NO security but requires the user to click a terms acknowledgement button in a browser window before their connection becomes fully active. Until it is clicked, the user can’t do anything. I assumed that the RS2 got stuck at this point because there is no way to click that button. But as with our main WiFi network, the RS2 claims to be connected but can’t be found.
I’ll check with out NetComm folks next.

Hi Pat,

I’ve checked that the WPA Enterprise security type indeed uses the PEAP authentication type. It’s weird that you can’t longer connect to the network if it was possible before. If the issue occurred after a firmware update, can you tell me which firmware was installed before and after the update? Does your uni network work at 2.4 GHz?

1 Like

Hi Kseniia-

Thank you for looking into this!
I’m afraid I don’t recall the firmware I had before- is there a way to check that in the system report or elsewhere? (I will share it w/ Emlid personnel but probably should not upload it here, as it may have sensitive information in it).
I’m pretty sure the last update was to my current version (28.2) on June 29th, 2002. Just not sure what I had before that.
Our WiFi is both 2.4 & 5 GHz (for the main and Guest networks).
Thanks again!
Cheers,
-pat

1 Like

I brought it up somewhere else and got a partial answer. If your network requires certificates on authentification, it will never work. Not supported. That’s the issue on our end.

1 Like

Hi Pat,

Sorry for the delay!

Our WiFi is both 2.4 & 5 GHz (for the main and Guest networks).

Reach receivers can work with 2.4 GHz but not with 5 GHz. Networks that support both 2.4 GHz and 5 GHz can confuse the receiver – that’s what could happen in your case. We recommend sticking to 2.4 GHz Wi-Fi to ensure a flawless connection.

Also, as Gabriel noticed, the ability to connect to the network via WPA Enterprise depends on the network requirements. For instance, specifying an authentification certificate is not available for now. But we’ve received a request about adding more settings recently, so I’ll add +1 to it.

RV3 will not let me “forget” the bogus one- only the one I created myself. The only way I can keep the RS2 from automatically connecting to the inaccessible network when turned on is to take it off-site or put it in a metal cabinet when I fire it up.

Have you tried to connect Reach to your mobile hotspot and remove all the known networks in the ReachView 3 Wi-Fi tab? If the receiver keeps connecting to the network after that, please let me know.

Hi Kseniia-

I have no control over the way our campus WiFi is set up, so I can’t turn off the 5 GHz SSIDs to prevent them from confusing the receiver. That and the certificate issue basically mean I can’t use the RS2 on our network. Maybe a firmware update in the future will fix this.

Yes, I can start the RS2 in a metal cabinet to force it to go into self-hotspot mode, and then delete all the known networks except my phone’s hotpsot. Then when it is restarted it will not try to connect to the “confusing” one, and will connect to my phone’s hotspot if it is on (or go into self-hotpot if not). But I can find no way to adjust the priority or order of known networks to make it always use my phone if it is on… Which is why if the “confusing” network is in the list, it will often try to connect to it (and only connect halfway) even if my phone hotspot is available. The ability to set the order of preference for known networks would be nice as well.
Thanks!

1 Like

Hi Pat,

We’re considering providing 5 GHz Wi-Fi support on our devices in the future. But there are no details or time estimations for now.

The ability to set the order of preference for known networks would be nice as well.

It is indeed not possible to set the Wi-Fi networks priority. But I’ve passed the idea to the team. Thanks for sharing it!

1 Like

Thanks Kseniia!
Both of those (5GHz & prioritizing SSIDs) would be very welcome. Perhaps also a way to force the receiver to forget all wireless networks using a series of button presses or USB connection or something would be good. It is very frustrating when a network that won’t end up working gets entered and the receiver always jumps to it @ startup.

1 Like

Hi Pat,

a network that won’t end up working gets entered and the receiver always jumps to it @ startup

If you connect to the Reach hotspot and delete the saved networks from the Wi-Fi tab, it shouldn’t happen again. So, just to check if I get it right why you need this option – is it possible not to re-enter the non-working network credentials once deleted? Or is it a kind of uni requirement to have a specific network saved on the receivers?

1 Like

The problem is that if the credentials are entered and the Reach connects only “halfway” to the “bad” network. It will do so EVERY TIME it is started up, unless it is taken to where it can’t see the network, the network is turned off, or it is started up in an enclosure that shields it from the network (like a paint can or metal cabinet). It will not go into hotspot mode otherwise, so one can’t delete the bad network(s). This is very inconvenient and in some cases a huge time sink.
So a way to either force it to forget all networks, or to force it to go into hotspot mode on startup is needed, for those occasions where a network is added that will not work for the RS2.

1 Like

Hi Pat,

It will not go into hotspot mode otherwise, so one can’t delete the bad network(s). This is very inconvenient and in some cases a huge time sink.

I see that taking the units to another place can take some time. But it’s enough to delete the non-working Wi-Fi once on all your devices, and they won’t connect to it again. You can do it as follows:

  • Place the units in a location where the Wi-Fi network is not available.

  • Turn Reach on. It will create a hotspot.

  • Connect to the Reach hotspot, go to the ReachView 3 Wi-Fi tab, and delete saved networks from the list.

After that, each time you turn on your units, they’ll go to the hotspot mode. If you need to provide Reach with Internet access, you can add another 2.4 GHz network, such as your mobile hotspot, in the last step.

Hi Kseniia-

Yes, I think we have established the workaround procedure that works. No need to keep reiterating it. My point was that “taking the units to another place” is onerous and sometimes just not possible. If there was a way to FORCE hotspot mode (by a series of button pushes @ startup or something) or to delete all known networks, that would remove the need to

We currently have an inconvenient workaround. The solution I am proposing is much more elegant.

Thanks again for your attention to this matter.

1 Like

Hi Pat,

Thanks for explaining that! See your point. I’ve shared your idea with the team.

1 Like

Thanks Kseniia!

Much appreciated.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.